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1 Translating Info Objects with the SAP KW
Translator

Purpose

The SAP Knowledge Warehouse Translator is a tool with which you can use to translate info objects from
different Info Object Classes and areas:

e Objects of class Text / Slide (format: DOC / PPT)

® Objects of class Visio objects (format VSD / only in QM Manual area)

® (Objects of class multimedia objects (in any format)

e Objects of the class HTML (only in the HTML-Based Documents area)

The SAP KW Translator is a front-end application for Microsoft Windows permitting easy editing of translation
packages (Explorer, status management).

Files in a format that cannot be edited can be translated by checking in an existing file as translation
(multimedia translation).

You can translate the specified info objects using the SAP KW Translator without a link to an SAP Knowledge
Warehouse system.

Implementation Considerations

The SAP KW Translator, as part of the SAP KW Add-On, is necessary on every front-end that is to be used for
the translation of packages of type SAP KW Translator (without Trados).

Integration

In the SAP Knowledge Warehouse translation packages of type SAP KW Translator (without Trados) are
created.

Features

e Supportin translation of all formats that are registered in SAP KW, such as
o Microsoft Word, Microsoft PowerPoint, Microsoft Visio
o Other Microsoft Office formats such as XLS
o HTML
Images / Graphics
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Insertion of translated files in the translation package
Semi-automated status management
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2 Translation of a Translation Package

Purpose

You can translate a translation package that was created in one of the default areas of the SAP Knowledge
Warehouse (such as training, documentation, QM manuals).

The translation package contains all the components of the chosen folder or content objects.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

Process

1. You start the SAP KW Translator.
2. You open the translation package.

3. The contents of the translation package are displayed sorted by the component of the content objects to
be translated.

4. You translate the contents of the translation package.

5. With an editor, you can only translate a content object that is marked as the primary component and
whose technical name is displayed.
Primary components are objects that were checked into SAP KW as independent content objects.
If you want to translate other components of the content object using an editor, you must mark these
components as primary components.

6. You assign Translated status.
Only translation packages whose content objects have Translated status can be checked in.

7. You close the SAP KW Translator.

Result

The translation package is translated and can be read back into SAP KW system.
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2.1 Starting the SAP KW Translator

Prerequisites

The SAP KW Translator was installed with the SAP KW Add-On in addition to the SAP GUI for Windows.

Procedure

To start the SAP KW Translator, choose SAP KW Translator (under SAP front-end).

Result

The SAP KW Translator is started.

2.2 Setting the Interface Language

Prerequisites

You are in the SAP KW Translator.

Procedure

To set the interface language of the SAP KW Translator, proceed as follows:

1. Choose |» Extras » Options...

2. Adialog box appears in which you can enter general settings.

3. Choose the interface language for the SAP KW Translator in the Language field and choose OK.

Result

The interface of the SAP KW Translator appears in the given language.
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2.3 Opening the Translation Package

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the PC.

You are in the SAP KW Translator.

Procedure

To open a translation package, proceed as follows:

Choose ||r File » Open Translation Package...
The Open Translation Package dialog appears.
Go to the directory where you stored your translation package.

AW

Choose file trans.kxf and choose Open.

Result

The chosen translation package is opened in the SAP KW Translator.
The technical names of the content objects to be translated are displayed.

If you expand the individual content objects, you will see the individual components belonging to the content
object.

The primary components are translated.

2.4 Translating a Content Object with the Editor

Use

In the SAP KW Translator you translate content objects of Info Object Classes Slide, Text (or Topic), and Visio
Objects using MS PowerPoint MS Word or MS Visio. These applications are started automatically when you
want to translate content objects.

Content objects of info object class HTML can be translated in a special HTML editor provided by the SAP
Knowledge Warehouse.
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Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

The translation package contains content objects of Info Object Classes Slide, Text(or Topic), Visio Objects, or
HTML.

You are in the SAP KW Translator.

The content object to be translated is identified as a primary component.

Procedure

To translate a content object with the appropriate editor, proceed as follows:

1. Double-click on the content object.

2. The appropriate editor is started. The content object is marked as open in the SAP KW Translator.
Two windows are displayed. One window contains the original language file and the other one contains the
target language file.

i Note

If you only see one window (for example, when translating HTML objects), move this window. The
second window lies below it.

3. Translate the content object and save the translation.
4. Close the editor.

Both windows are closed.

If this is not the case, close the windows manually.

Result

The content object is translated. It is marked with status In Process in the SAP KW Translator.

After completing the translation of the content object, you should set the status to Translated, so that the
object is definitely included when the translation package is imported.
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2.5 Assigning a Translated File

Use

You can assign any file to the components of a content object as a translation, thereby creating a translation
without an editor.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To assign a translated file to a component, proceed as follows:
Select a component.

Choose |jr Edit » Assign Translated File...
A dialog box appears.

2w e

Go to the directory containing the file you want to assign as translation.
5. Choose the file and choose Open.

If you chose a primary component to which you want to assign a translation, you can assign further
components as translation. Confirm the query regarding the assignment of additional files for translation with
Yes. If only one component exists then choose No in the query.

Result

The chosen file was assigned to the chosen component as translation.
The content object is marked with the status In Process in the SAP KW Translator.

Set the status to Translated when you have completed the translation of the content object.
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2.6 Translating the Title

Use

You can translate the title of a multimedia object with this procedure.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To translate the title, proceed as follows:

1. Choose a multimedia object.

2. Choose |j» Edit » Translate Title
If you execute this function for an info object of the class Slide, Text (or Topic) or Visio objects, you receive
the message: The title of the document does not need to be translated separately because it is part of the
document for objects of this Info Object Class.

3. The Translate Title dialog box appears.
4. Enter the translated title in the lower part of the window and choose OK.

Result

The title of the chosen content object is translated. The object is marked with the status In Process in the SAP
KW Translator.

2.7 Local Translation Status
Definition

The local translation status indicates the translation status of a content object in the translation package.

In some cases it is set automatically, but you can also set it yourself.
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Use

You can indicate the translation status of a content object with the local translation status.

Structure

The local translation statuses are:

e Unchanged
The content object has not been translated yet.
This status is set automatically.

® |nProcess
The content object has been opened and saved in the editor, or a translated file has been assigned to the
content object. The translation of the title of multimedia objects also triggers the status change, if
previously an activity for this object has been carried out.
This status is set automatically.

e Translated
The content object has been completely translated.
You set this status yourself.

2.7.1 Setting the Local Translation Status

Use

You can indicate the translation status of a content object with the local translation status.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To assign a local translation status to a content object, proceed as follows:

1. Choose the content object.

2. Choose |» Edit » Mark Document As » Unchanged i or In Process or Translated.
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Result

The local translation status is assigned to the given content object.

2.8 Changing the Components

Use

You can change the components of a content object with this function.

Integration

A content object can consist of multiple components, where the content object is the primary component.

» Example

Multimedia object with several files.

Only the primary component can be translated with an editor. Therefore, if you want to translate a component
of the content object using an editor, you must first declare this component to be the primary component.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Features

The following functions for changing components are provided:

® Declare a component to be the primary component
The file marked as the primary component can be translated with an editor.

e Add new components
® Replace one or all component files with other files
e Delete components
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Activities

You mark one or more components and choose ||» Edit » Component Files... i and then one of the displayed
options.

2.8.1 Declaring a Component to be a Primary Component

Use

If you want to translate a component using an editor, this component must be marked as the primary
component.

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To declare a component as the primary component, proceed as follows:
1. Choose the components to be translated with an editor.

2. Choose |» Edit » Component Files » Declare Component File As Primary

Result

The chosen component is marked with an icon as the primary component. It can now be translated with an
editor [page 7].

Translating Documents with the SAP KW Translator
Translation of a Translation Package PUBLIC 13



2.8.2 Adding a New Component File

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To add a new component, proceed as follows:

1. Choose a content object to which you want to add a new component.

2. Choose ||¢ Edit » Component Files... » Add Component File

3. Adialog box appears.

4. Go to the directory containing the file you want to add as a new component.
5. Choose the file and choose OK.

Result

The new component is added to the content object.

2.8.3 Replacing a Component File

Prerequisites

The translation package to be translated was created with the SAP KW Translator (without Trados) option and
is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To replace a component, proceed as follows:
1. Choose a component to be replaced.

2. Choose |» Edit » Component Files... » Replace Component File
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3. Adialog box appears.
4. Go to the directory containing the file with which you want to replace the given component.
5. Choose the file and choose OK.

Result

The chosen component is replaced.

2.8.4 Deleting a Component File

Prerequisites
The translation package to be translated was created with the SAP KW Translator (without Trados) option and

is stored on the front-end.

You are in the SAP KW Translator.

Procedure

To delete a component, proceed as follows:

1. Choose a component to be deleted.

2. Choose |» Edit » Component Files... » Delete Component File

Result

You have deleted the selected component.
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Important Disclaimers and Legal Information

Hyperlinks

Some links are classified by an icon and/or a mouseover text. These links provide additional information.
About the icons:

o Links with the icon o : You are entering a Web site that is not hosted by SAP. By using such links, you agree (unless expressly stated otherwise in your
agreements with SAP) to this:
e The content of the linked-to site is not SAP documentation. You may not infer any product claims against SAP based on this information.
e SAP does not agree or disagree with the content on the linked-to site, nor does SAP warrant the availability and correctness. SAP shall not be liable for any
damages caused by the use of such content unless damages have been caused by SAP's gross negligence or willful misconduct.
e Links with the icon &: You are leaving the documentation for that particular SAP product or service and are entering a SAP-hosted Web site. By using such
links, you agree that (unless expressly stated otherwise in your agreements with SAP) you may not infer any product claims against SAP based on this
information.

Beta and Other Experimental Features

Experimental features are not part of the officially delivered scope that SAP guarantees for future releases. This means that experimental features may be changed by
SAP at any time for any reason without notice. Experimental features are not for productive use. You may not demonstrate, test, examine, evaluate or otherwise use
the experimental features in a live operating environment or with data that has not been sufficiently backed up.

The purpose of experimental features is to get feedback early on, allowing customers and partners to influence the future product accordingly. By providing your
feedback (e.g. in the SAP Community), you accept that intellectual property rights of the contributions or derivative works shall remain the exclusive property of SAP.

Example Code

Any software coding and/or code snippets are examples. They are not for productive use. The example code is only intended to better explain and visualize the syntax
and phrasing rules. SAP does not warrant the correctness and completeness of the example code. SAP shall not be liable for errors or damages caused by the use of
example code unless damages have been caused by SAP's gross negligence or willful misconduct.

Gender-Related Language

We try not to use gender-specific word forms and formulations. As appropriate for context and readability, SAP may use masculine word forms to refer to all genders.
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